What's new

 

What's new

Previous pageReturn to chapter overviewNext page

Here is the list of improvements and enhancements that were included into different ABViewer releases:

ABViewer 12

Support of AutoCAD® DWG 2018

Speed of PDF to DWG conversion increased

DWG/DXF to G-code conversion

Hiding of all 3D model parts except for the selected ones: 3D Structure

Adjustment of the scale factor for 3D measuring: Options. Measure

PDF to DWG: an option enabling to configure conversion of images added

ABViewer 11.2

PDF to DWG: vectorization of raster images during conversion added

ABViewer 11

Measuring of STEP and IGES files

Loading of custom line types

Saving to DWG 2004

Support of big SHX fonts (for Asian characters)

Batch print improved greatly

New Align tool

New Pan tool

Possibility of layouts duplicating

PDF to DWG conversion improved

Saving of measurement results to TXT

ABViewer 10.0.1

Import PDF/EMF command imports PDF, EMF and WMF files in vector format

Page to CAD command converts the active layout of the loaded file into the DWG/DXF vector format

Entities scaling against base segment (the Relative scale mode)

ABViewer 10

Convenient navigation in 3D mode while viewing 3D models

Copy with base point

Embedding of Xref files into the current drawing

Deleting of segments with one mouse click on the internal and external side of the selected outline

Quick access to CAD file settings, layers and layout options from the window Batch print

The window Structure completely renewed, search and access to files added

Export into 3D files formats: STL, OBJ, OBJF, NMF, LMTS

Saving in DXF 2007

Export of bit-mapped images into DWG and DXF in the window Batch

Command Convert to polyline converts the selected object into a polyline

Command Show performs zooming of the selected objects in the window of the program working area.

Commands Explode all and Explode all inserts break connections between all compound objects in the drawing

The option Show contours of composite objects added which includes showing of the objects contours while relocating complex objects

Polyline editing improved and now parallel relocation of line segments is possible

The option Fillet for polyline that enables the user to create arc segments of a specified radius

The opportunity of filtration added in the window Layers

Command line improved, system variables added.

ABViewer 9.1

View and measure of  3D files of IGES, STEP, SAT, BREP formats

XML API via DDE (see also CADEditorX)

Compare files

Display of plot settings and their use for printing

Georeferencing  (sheet coordinates are replaced with geo coordinates)

Command Line

LISP

Export to DWG

Batch Print is improved

Dimension Styles for Measurements

ABViewer 9.0

Added support of AutoCAD™ DWG 2013

ABViewer 8.2

Display quality of DWG, DXF, CGM file formats improved

Reading and editing dimension styles improved

Possibility to paste metafiles from the clipboard added

Export to PDF improved

The possibility to move the tabs of the opened drawings added

The work of tools Copy as BMP and Copy as EMF when copying the image with the current size improved

The mode Block editor is marked with a blue frame

The work of the command Undo/Redo for blocks improved

The total number of circle and spline splitting is used for all the entities

The work of Measure tools improved

Saving the layer color set in RGB, corrected

Interface improved

ABViewer 8.1

Tracking and the modes Parallel and Extension added

Snap modes Quadrant and Tangent added

The command Poly entity input added

Possibility to create and use file templates added

Possibility tosave and send drawings per e-mail added

New easy way of editing entities: moving elements by a single click on them, using the key Shift to disjoin markers.

The mode of slow zoom in/out added

The interface of the dialog box Options changed

Settings Don't save network paths, Add comments to the file added

Work of the setting Adjust Display Scale changed

Work of the tool Match Properties changed

Work of the tool Trim changed

Command Full Screen is in the Ribbon under the tab Viewer

Floating Panel Measure improved

Work with blocks improved

If Xref wasn't found in the specified path, the search will be effected in the folder containing the file.

Display quality of DWG, DXF, DWF, CGM, PLT files improved

ABViewer 8.0

Ribbon interface

Dynamic input for the object to be created and edited

Report on attributes added

Table entity added

Viewports editing (highlighting, scaling, moving of the entities, pop up menu) improved

OLE entity added

Possibility of pasting raster images and texts from clipboard

Saving raster images into DXF when they are pasted from clipboard as an OLE object

Full Unicode support

CGM, SVG, DXF, DWG and PLT formats display improved

Export to CGM, SVG and DXF improved

ABViewer 7.4

PDF/EPS import added

CGM import improved

General operation improved

ABViewer 7.3

3D files' support was added.

New '3D View' layout was added for dwg/ dxf files.

Full screen mode is available.

The list of layers in "Properties" panel is now arranged alphabetically.

Scale combo-box has been excluded from the application interface.

Visualization of drawings has become much faster.

ABViewer 7.2.5

Hatch improved:

-  insertion of hatches by a click on any point inside a closed area (“Draw -> Hatch -> Select point”);

-  highlighting of the contour to be filled with hatch;

-  use of 'Fast Entities Input' button for selecting the necessary contours.

User-definable settings for export into PDF.

New Purge feature allowing deletion of unused elements from the drawing.

Block editor.

Full screen view mode available.

Possibility to undo the last part of Polyline or Spline by Ctrl+Z hotkeys.

'Height' property added for Arc and Spline entities.

New Snap type - 'Normal' - finding the perpendicular to a line.

More user-defined settings for the Cursor added.

ABViewer 7.2

Block insertion tools are added (“Draw ->Block”) .

The possibility to create gradient hatches (“Draw -> Hatch”).

“Measure” tool improved: it now allows measuring angles, copying data to the clipboard (“View -> Measure” or “Tools  -> Measure”).

Image insertion tool improved (“Draw -> Image”).

External reference (Xref) insertion tool improved (“File -> Merge”).

Saving into DXF 2004  added (major improvement is the correct saving of gradient hatches).

New “Wipeout” entity with the possibility of showing and hiding the boundaries of the Wipeout area (“Draw -> Wipeout”).

The possibility to select a whole entity by its part (selecting with a rectangle in “bottom to top” direction)

ABViewer 7.0

Multiple document interface (MDI) is supported. Selecting color style and customizing toolbars is available.

Context help is supported (press F1 key when the mouse cursor is over the necessary control or menu item).

Support of Autodesk Design Web Format DWF file format has been added.

Support of Autodesk Binary DXF file format has been added.

Conversion to Adobe Flash SWF file format is supported.

Conversion to SVG and CGM file formats has been improved.

Speed of conversion to DXF files format has been increased 5 times.

Complex line types support has been added.

New CAD entity is supported - WIPEOUT.

New CAD entity is supported - MLINE.

New CAD entity is supported - HELIX.

Support of INSERT entity with predefined number of rows or columns.

Support of IMAGE entity with clipping.

Inserting raster images.

Creating Layouts and ViewPorts.

Creating blocks with attributes.

Editing block attributes dialog window is available.

Creating and editingText Stylesis available.

Creating and editing Dimension Styles is available.

RW Memory use has been enhanced (which is essential with files containing a big amount of CIRCLE, ARC and ELLIPSE entities).

Distance tool has been improved.

New tools:

oPolar Tracking

oQuick Select

Lots of modifying tools have been added:

oMatch Properties

oMirror

oRotate

oMove

oCopy object

oScale

oTrim

oBreak

oBreak at point

oExplode

oFillet

oBevel

oUnion

oExtend

Working with layers has been improved.

ABViewer 6.3

Conversion to Computer Graphics Metafile (*.cgm) file format has been added.

Conversion to Scalable Vector Graphics (*.svg) file format has been added.

Import of Adobe Post Script (*.ps) file format has been added.

Speed of displaying SHX texts has been improved.

Editor:

oOpportunity of defining width for MTEXT entities has been added.

oA drawing does not change its size on adding new entity.

New printing option - printing all pages (layouts) of the file.

Bugs have been fixed.

ABViewer 6.2

New CAD entity is supported - TOLERANCE.

New CAD entity is supported - TRACE.

New DWG entity is supported - ACAD_TABLE.

Entity's displaying is improved - ACAD_PROXY_ENTITY.

Entity's displaying is improved - LEADER.

Entity's displaying is improved - LWPOLYLINE.

Entity's displaying is improved - MTEXT.

Entity's displaying is improved - SPLINE (with zero Start/End-tangents).

Displaying files of HPGL-2 and PCL formats is improved.

Displaying files of DWG format versions up to «AC1009» (R12) is improved.

Support of the oldest DWG file format versions (up to «AC1002») is added.

Resulting PDF file size is decreased in ten times when converting to PDF file format.

Speed is increased in three times when converting to DXF file format.

Displaying files of TIFF format is increased.

ABViewer 6.1

Export to HPGL/2 file format is added. Multi pages and rectangle viewports are supported.

Converting to DXF supports enhanced Unicode symbols (hieroglyphs etc.).

DXF loading has been optimized for files with big amount of blocks (layers and styles). In some cases speed is increased up to ten times.

Enhanced work with mm / inches is added. It is used:

oin printing (defining correspondence between drawing's unit and it's size);

omeasure tools (Distance, Area and Polyline Length).

New Snap abilities: snapping to lines, line centers and intersection points.

Big rasters shown better with smoothing technology.

Speed when viewing and scaling raster images has been increased in times.

Gradient filling for complicated types is implemented.

Enhanced Unicode symbols for TTF fonts are supported.

All ANSI-codepages are supported.

Bugs fixed:

oincorrect displaying of HPGL/2 page sizes;

oincorrect viewing of some Backward texts;

oincorrect printing of some gradient fillings;

oincorrect viewing of raster images in block;

obugs when converting SVG to DXF.

ABViewer 6

New editing ability makes ABViewer full functional editor of CAD files and raster images.


New panel Properties gives an access to entities' properties and allows changing them on the spot.


New option Set size as gives flexible access to the drawing's dimensions. It allows making precise measurements on the CAD drawings with several scale factors or to measure raster images.


New feature Thumbnails makes access to files faster and easer.


AutoCAD™ DWG 2007 file format is supported.


Converting to the Adobe Acrobat Document PDF file format is supported.


Converting to AutoCAD™ DXF file format has been improved significantly.


AutoCAD™ PROXY (including AEC) entities are supported.


HPGL/HPGL2 file format -  Bezier splines are supported.


CALS Images (*.cal) are supported.


Pens for HPGL/2 files are available as a Layers list.


Main menu contains new item Draw. It contains commands for adding new entities to the drawings.


Main menu item Edit contains additional sub items which allow copying, pasting, deleting etc. entities in the drawing.


Main menu item File contains additional sub item Print View Area. It allows to print only visible part of the loaded image.


Measuring tools:

oMeasuring polylines - new Tools > Polyline length menu command allows measuring polylines on the images.

oMeasuring areas - new Tools > Area menu command allows measuring areas on the images.


Options dialog box contains new tab Units. Its settings influence on the results of Tools > Distance menu item usage.


Snap to inserts - this option allows snapping to the block's insert point.

ABViewer 5.2.5

HPGL: fixed bugs with gradient filling.


Scaling factor has been increased in 32 times under WinNT, Win2000 and WinXP.


Loading files of supported formats from archives (zip, gz, tar).


Favorites menu has two additional items:

oSend to Batch

oSend to Batch Print

ABViewer 5.2.0.125

Viewing of HPGL files became significantly faster. Requirements for memory lowered.


The original way of loading, storing and drawing of TTF fonts has applied.


Floating License Registration is supported.

ABViewer 5.2

Snap (RedLine and Distance can use Snap).


Added support of BigFonts in AutoCAD™ DWG/DXF files.


Using default SHX font if necessary is absent.


A lot of corrections in AutoCAD™ DWG 12, SVG and CGM file formats.


Added support of AutoCAD™ DWG 9, 10 and 11.


The Options dialog window (available on Tools > Options menu command) has a new tab Converting settings.


CAD format files auto rotation when opening (important for HPGL files).


New shortcuts: Distance (Ctrl + D), Rotate Counter Clockwise (Ctrl + left arrow), Rotate Clockwise (Ctrl + right arrow).


Edit > Find Point menu commands allows finding 3d point.


Customizing image size for copying to clipboard.


Max possible sizes for exported raster formats are increased.

ABViewer 5.1

ABViewer is available in two versions:

oProfessional Version

oStandard Version.


The new File > Merge menu command allows merging of several CAD format files.


The new File > Batch Print menu command provides ability to print a batch of chosen files.


The new Edit > Find Point menu command provides finding of the required point in the drawing.


The new Edit > Find Text menu command provides finding of the required text string in the drawing.


The new CAD files > Dimensions Show menu command provides the showing/hiding dimension lines.


The new CAD files > Texts Show menu command provides the showing/hiding texts.


Improved option available by CAD files > Show Layers menu command.


The CAD files > 3D Views menu command is enlarged with the additional views.


Options menu item moved to the new menu item Tools.


The new Tools > Redline popup menu command provides a set of tools for creating, editing and saving Redline patterns.


The new Tools > Distance menu command provides the measuring of distance between two points in the drawing.


The Options dialog window (available on Tools > Options menu command) has a new tabpage Redline. This tabpage includes Grid options of Redline.


The CAD Files > Show Lineweight and CAD Files > Hide Lineweight menu commands are brought together to a Show Lineweight menu item.


The CAD Files > Arcs Split and CAD Files > Real Arcs menu commands are brought together to an Arcs Split menu item.

ABViewer 5

Viewing Viewing TIFF, SVG (restricted functionality), CGM, BW, CEL, CUT, DIB, FAX, GED, ICB, ICO, JPEG, JPG, PAL, PBM, PCD, PDD, PIC, PGM, PNG, PPM, PSD, PSP, RGB, RGBA, RLA, RLE, RPF, SGI, TGA,  VDA, VST, WIN formats. Working with GIF, DWG, DXF, GL2, HG, HGL, HPG, HP, HP1, HP2, HPGL, HPGL2, PCX, PLO, PLT, PRN, SPL formats was improved.


The File > Print Preview... CADImage tabpage has new features for defining and scaling line's weight.


The new File > Batch Print menu command is available.


The Options > Visualization tab page has new features:

oDouble buffering reduces the amount of flicker when the image repaints, but is more memory intensive.

oBorder around CAD image for adding the border around the image for the best visualization.


The menu command Options > Options... has new tab page 'SHX Fonts'. It allows the use of SHX CAD fonts.


The new File > Batch menu command allows user to convert selected file(s) to *.bmp, *.emf, *.wmf, *.jpg, *.gif, *.tiff and *.dxf formats.


The menu command Options > Options... has a new tab  'Soft Gold Direct'. It defines an ability of connection to proxy-server for manual or auto update check. The property 'Quality' of 'Visualization' now allows one to set up the number of lines in which circles, circle arcs, ellipses, elliptic arcs and splines would be split up for the best quality.


The new CAD files menu commands allows drawing top, bottom, left, right, front, back or initial view if AutoCAD™ DWG, DXF or Hewlett-Packard HPGL file loaded.


The new View > Rotate (Counter clockwise, Clockwise, by Angle) menu command allows users to rotate an image.


The CAD files > White background menu commands now available as CAD files > Custom background menu.


The View > Back > Forward menu commands and are available now as View > Back > Forward menu commands and .


The new View > Next > Previous files in directory menu command and allows users to view files in current directory.


New support of animated *.gif files.


The zoom dropdown list in the toolbar was expanded by new default dimensions (1%, 5% and 25%).

ABViewer 4.4

'Export file size' dialog box (Save Picture... menu command) was expanded. It allows users to define the actual size, maximum and custom sizes, pixels, millimeters of an image.


Menu command Options > Options... the 'Visualization' tab page has a new property 'Quality'. It allows users to set up the quality of drawn arcs and splines.


Property 'Close on' of the 'Common' tab page of the menu command Options > Options... tab page consist of two points:

o'Escape'

o'F10'

o'F3' was excluded.


The new CAD files > Change Background Color menu command allows user to choose custom background color.


New options are available when AutoCAD™ DWG, DXF or Hewlett-Packard HPGL files are loaded in 'Structure' mode. On the left side of the tree view, right click, a window appears with two items: 'Find... Ctrl + F' and 'Find Next F3'. On the right side of the tree view, right click, a window appears with 'Copy Ctrl+C'.


The Print Preview menu command property 'Additional settings' has new option 'Frame offset'.  Specifies the offset from original frame if it exists.

ABViewer 4.3

'Export file size' dialog box while saving picture was added. It defines the size of an image.


The new Favourites > Add From Folder menu command allows user to add all supported files from selected folder to Favorites.


Support of the layouts viewing. Layout combo box accesses virtual drawing sheets viewing.


It is now possible to view drawings with a large scale factor. You can view a very small drawing element.


It is possible now to view *.dxf, *.dwg and *.hpgl formats with better quality.

Go to ABViewer